EU - Batch Update Process - Delay in Campaign execution

Incident Report for Optimove Service

Resolved

This incident has been resolved.
Posted Mar 14, 2026 - 10:10 UTC

Investigating

We are currently experiencing unexpected errors leading to delays in campaign execution.

What We’re Doing:
Our engineering team is actively investigating the root cause and working to restore normal execution as quickly as possible.

Next Update:
We will provide an update within 1–2 hours, or sooner if new information becomes available
Posted Mar 14, 2026 - 09:02 UTC
This incident affected: Europe (Batch Data Process).