Batch Update Process - Delay in Campaign execution

Incident Report for Optimove Service

Resolved

The issue impacting batch data processing has been fully resolved. Our vendor has confirmed that service restoration was completed as of 06:10 UTC and subsequent monitoring has verified system stability.
Posted Jun 12, 2025 - 10:32 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 09:36 UTC

Monitoring

Our vendor has confirmed that the issue was resolved as of 06:10 UTC. The root cause was identified as a configuration issue within a set of core services in the affected region, which temporarily impacted access to key data infrastructure.

We are observing recovery across the impacted batch processes in both the US and EU regions. Our team is actively monitoring system performance to ensure that all services remain stable. Some delays in campaign execution may still occur as the system fully stabilizes.

We will provide further updates as needed.
Posted Jun 12, 2025 - 08:27 UTC

Update

We have received confirmation from our infrastructure provider that a fix has been deployed to the affected core services. Preliminary indicators show signs of recovery, and we are closely monitoring system metrics to ensure stability is maintained.

At this time, batch data processes in both the US and EU regions are beginning to stabilize. However, some delays in campaign executions may still occur until full service is restored.

We will continue to monitor the situation and provide another update within the next 60 minutes or as soon as new information becomes available.
Posted Jun 12, 2025 - 07:44 UTC

Identified

We’ve traced the source of the elevated errors in our batch update system to an outage affecting our underlying data infrastructure. This disruption is currently impacting a broad segment of our clients across both US and EU regions.

Due to this, scheduled campaign executions may be delayed until normal service is restored. Our team is actively monitoring the situation and will continue to provide updates as more details become available.
Posted Jun 12, 2025 - 03:47 UTC

Investigating

We are investigating elevated errors in our batch update process. Specifically, we are facing an issue with one of our cloud-based data warehouses.

This issue is affecting a significant number of clients across both the US and EU regions who are on the same data warehouse. As a result, scheduled campaign executions may experience delays during batch processing.
Posted Jun 12, 2025 - 03:22 UTC
This incident affected: Europe (Batch Data Process) and USA (Batch Data Process).